Datamaker DB2 database connection fails with SQL30082N Security processing failed with reason "15" ("PROCESSING FAILURE"). SQLSTATE=08001
search cancel

Datamaker DB2 database connection fails with SQL30082N Security processing failed with reason "15" ("PROCESSING FAILURE"). SQLSTATE=08001

book

Article ID: 398260

calendar_today

Updated On: 05-20-2025

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Post upgrade to 4.11.20.0 Data maker, we are not able to connect to DB2 databases:

ERROR:

[IBM][CLI Driver] SQL30082N Security processing failed with reason "15" ("PROCESSING FAILURE"). SQLSTATE=08001

Environment

GT Datamaker 4.11.20.0

Cause

The error SQL30082N Security processing failed with reason "15" ("PROCESSING FAILURE"). SQLSTATE=08001 typically indicates a security violation was detected by DB2. The user trying to use DB2Connect is not authorized.

Looking at the Datamaker log, it shows the following error:

Error:  Unable to connect to Database.

Profile:              DB2Q

Title:    Data Source

Database Error Message:     SQLSTATE = IM004

[Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed

Transaction Error Code:        -1

Database Error Code:             999

 

CA Test Data Manager - Datamaker Details:

GUI Version:   4.11.20.0(Runtime: 22.2.0.3356)     (4/1/2025 17:20:12)

REP Version:  4.12.0.08

 

Transaction Details:

PB DBMS driver:          odbc

ODBC Driver: ibm db2 odbc driver

ODBC DBMS Name:

Server DBMS: ()

User ID:            <username>

DBParm:          ConnectString='Driver={IBM DB2 ODBC DRIVER};hostname=<hostname>;port=<port>;database=<db2_database>;currentIsolation=2;enableBulkLoad=true;retrieveMessagesFromServerOnGetMessage=true;keepDynamic=true;progressiveStreaming=2;Protocol=TCPIP; UID=<uid>; ',ConnectOption='SQL_DRIVER_CONNECT,SQL_DRIVER_NOPROMPT',DelimitIdentifier='NO'

AutoCommit: false

Whereas, the error "SQLSTATE IM004, Driver's SQLAllocHandle on SQL_HANDLE_ENV failed" generally indicates an ODBC driver mismatch.

Resolution

The issue was resolved by launching the GT Datamaker application with admin privileges. It's a recommended best practice to always launch the TDM applications 'as admin' whenever possible.

Additional Information