Unable to download attachments in Broadcom SAAS
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Unable to download attachments in Broadcom SAAS

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Article ID: 398248

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Unable to download attachments or some attachment in Clarity SAAS, 

Possible errors:  "Couldn't download - Something went wrong. Try again or contact your organization." Or "Site wasn't available".

Error in app-ca log 

ERROR 2025-05-19 14:28:38,804 [http-nio-8080-exec-28] pagebuilder.FilePageBuilder (clarity:admin:9894225__0A8714AA-8034-42ED-A9EE-49C9EFAB0CC3:PPM_REST_API)
(d01f500a-ad4a-498d-a337-9ca11297d56c) File "5244525" not found in path "/opt/ppm/files/filestore/clarity/Files/244/005"
ERROR 2025-05-19 14:28:38,804 [http-nio-8080-exec-28] ppm.rest (clarity:admin:9894225__0A8714AA-8034-42ED-A9EE-49C9EFAB0CC3:PPM_REST_API)
(d01f500a-ad4a-498d-a337-9ca11297d56c) Error while loading Attachment Data from Document Manager.Could not retrieve file from file store.

ERROR 2025-05-19 14:28:38,804 [http-nio-8080-exec-28] ppm.rest (clarity:admin:9894225__0A8714AA-8034-42ED-A9EE-49C9EFAB0CC3:PPM_REST_API) (d01f500a-ad4a-498d-a337-9ca11297d56c)
com.ca.ppm.rest.exception.APISystemException: API-1035 : Could not load attachment.

Environment

All Supported versions on Clarity SAAS

Cause

Filestore permissions issue

Resolution

Contact Broadcom Support to work with SAAS DevOps on the below: 

  1. Check the file is available on the server in the specified location
  2. Reapply permissions on the filestore folders