DNS-check: Perform Forward and Reverse DNS lookup tests on SDDC components fails.
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DNS-check: Perform Forward and Reverse DNS lookup tests on SDDC components fails.

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Article ID: 398240

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • Health check operation fails on the SDDC manager. DNS-check fails for forward and reverse DNS lookup on NSX edge nodes.

  • The description on the failure states - 

Reverse DNS lookup is NOT configured as expected,resolved dns xxxx.fqdn is not equal to xxxx.fqdn Forward DNS lookup is NOT configured as expected,resolved ip xx.xx.xx.xx is not equal to xx.xx.xx.xx

  • Running  /opt/vmware/sddc-support/sos --dns-health --domain-name DOAMINNAME returns RED status for the NSX edge nodes for Forward and Reverse lookup checks.
DNS lookup Status : RED
+-----+---------------------------------------------------------------------+--------------------------+-------+
| SL# |                                 Area                                |          Title           | State |
+-----+---------------------------------------------------------------------+--------------------------+-------+
|  1  |                NSX: xxxx.fqn               | Forward DNS lookup check |  RED  |
|     |                                                                     | Reverse DNS lookup check |  RED  |

Environment

VMware Cloud Foundation 5.x

Cause

Incorrect IP address is associated with the edge nodes FQDN/hostname from the SDDC manager Database - "vmManagementIpAddress":"xx.xx.xx.xx","vmHostname":"nsx_edge_fqdn"

Run the below command from the SDDC manager to validate the Edge node information from the SDDC DB - 

# psql -h localhost -U postgres -d platform -c "select id , name , nsxt_edge_nodes from nsxt_edge_cluster;"
                  id                  | name               |                                                                                                nsxt_edge_nodes

--------------------------------------+------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
xxxx-xxxx | nsx_edge_cluster   | [{"vmManagementIpAddress":"xx.xx.xx.xx","vmHostname":"edge01_fqdn","sourceId":"xxxx-xxxx","id":"xxxx-xxxx"},{"vmManagementIpAddress":"xx.xx.xx.xx","vmHostname":"edge02_fqdn","sourceId":"xxxx-xxxx","id":"xxxx-xxxx"},{"vmManagementIpAddress":"xx.xx.xx.xx","vmHostname":"edge03_fqdn","sourceId":"xxxx-xxxx","id":"xxxx-xxxx"}]
(1 row)

 

Resolution

Contact Broadcom Support as the resolution requires modifications on the SDDC manager database. 

Additional Information

The issue can be an outcome of updating the incorrect details on SDDC manager database after replacing edge nodes following article - Replace NSX-T Edge node in a cluster that is part of vCF/SDDC