NSX Manager cluster is down, UI is not accessible with error code 101
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NSX Manager cluster is down, UI is not accessible with error code 101

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Article ID: 398178

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX UI is not accessible and displays the following error:
    Error:
    Some appliance components are not functioning properly.
    Component health: Unknown
    Error code: 101
  • The NSX Manager is inaccessible after an Site Recovery Manager (SRM) failover.
  • The "get managers" command from the NSX Manager nodes indicates that all nodes are connected.

    host######> get managers
    -##.##.##.1 Standby
    -##.##.##.2 Connected 
    -##.##.##.3 Connected
  • However, "get cluster status" shows error "% An error occurred while getting the cluster status"
    nsxmanagernode> get cluster status
    % An error occurred while getting the cluster status
  • All the services on the nodes are active.
  • All the nodes can ping each other.
  • The following message appears in the var/log/cbm/cbm.log file:
    YYYY-MM-DDTHH:MM:SS.###Z INFO pool-17-thread-5 ClusterConfigurationManager 3254 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cbm"] allConfigRecords size = 0

Environment

VMware NSX

Cause

The 'allConfigRecords size = 0' entry in cbm.log indicates the cluster configuration is missing. As a result, the Cluster Boot Manager (CBM) fails to start due to missing configuration data.

Resolution

If you encounter this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.