NSX Manager cluster is down, UI is not accessible with error code 101
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NSX Manager cluster is down, UI is not accessible with error code 101

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Article ID: 398178

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX UI is not accessible and shows the following error
    Error:
    Some appliances components are not functioning properly.
    Components health: Unknown
    Error code: 101
  • NSX Manager post failover with SRM not accessible.
  • The "get managers" command from the NSX Manager nodes indicates that all nodes are connected.

    host######> get managers
    -##.##.##.1 Standby
    -##.##.##.2 Connected 
    -##.##.##.3 Connected
  • However, "get cluster status" shows error "% An error occurred while getting the cluster status"
    nsxmanagernode> get cluster status
    % An error occurred while getting the cluster status
  • All the services on the nodes are up.
  • All the nodes can ping each other.
  • You will see the following message in the following log file, var/log/cbm/cbm.log
    YYYY-MM-DDTHH:MM:SS.###Z INFO pool-17-thread-5 ClusterConfigurationManager 3254 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cbm"] allConfigRecords size = 0

Environment

VMware NSX

Cause

The entry 'allconfigrecords size = 0' in the cbm.log indicates that the cluster configuration is missing. As a result, the Cluster Boot Manager (CBM) is unable to start due to the absence of required configuration data.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.