The i5 job failed with error "Job does not exist on the system".

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Article ID: 3981

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent CA Workload Automation Agents DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

The i5/OS job submitted through the System Agent failed with warning message: "Job does not exist on the system". 

However, when the same job was run with the native i5 SBMJOB command from the system prompt it had completed successfully.

Cause

This situation might occur when the job had got its own Job Description.

Check if a particular i5 Job Description was defined to run the job.

Environment

i5 Servers (AS400) and System Agent release 11.3, any Service Pack

Resolution

Look at the 'Message logging' option in this Job Description: you need to have it as 4 0 *SECLVL :

Message logging:

  Level  ......................... :   4       
  Severity ....................... :   0       
  Text ........................... :   *SECLVL 

The Agent needs this level to read the job status properly.