Management interface is unavailable due to the Cassandra DB running in a degraded state
search cancel

Management interface is unavailable due to the Cassandra DB running in a degraded state

book

Article ID: 398085

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • The Management Interface is unavavailable.
  • Review of the /storage/core/loginsight/var/cassandra.log shows errors similar to the following two errors:
  • Cassandra server running in degraded mode. Is swap disabled? : false,  Address space adequate? : true,  nofile limit adequate? : true, nproc limit adequate? : true
  • CassandraRoleManager skipped default role setup: some nodes were not ready

Environment

Aria Operations for Logs 8.x

Cause

This issue can be caused by time sync between Operations for Logs cluster nodes.

Resolution

  1. Update NTP settings or sync nodes so they are time is synchronized between them.
  2. Gradually restart the cassandra database:

  3. SSH into one of the Operations for Logs nodes.

  4. Stop vRLI Daemon service on all nodes:

    • systemctl stop loginsight
  5. Make sure vRLI Daemon Service and Cassandra are stopped

  6. Start Cassandra on each nodes:

    • /usr/lib/loginsight/application/sbin/li-cassandra.sh --startnow --force
  7. Output should show:

    • Running LI stop........done
    • Starting Cassandra.....done
  8. Monitor the cassandra.log to ensure it comes up successfully.