Unable to discover a SNMP device in Spectrum
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Unable to discover a SNMP device in Spectrum

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Article ID: 398059

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Updated On:

Products

Network Observability

Issue/Introduction

We are trying to use the Discovery Console to discover a device in Spectrum, however the discovery always fails.

How can we troubleshoot this further to understand why the device cannot be discovered?

Environment

Spectrum : ANY

Spectrum Discovery

Cause

Device is not responding to SNMP Requests correctly

Resolution

To troubleshoot discovery issues, its necessary to have a tcpdump (Linux) or Wireshark (Windows) from the SpectroSERVER that you are trying to discover the device from.

1. Start the tcpdump / wireshark trace on the SpectroSERVER

2. Start the discovery from OneClick

3. Once the discovery fails, stop the tcpdump / wireshark,

 

You can open the pcap file with Wireshark and then look at the SNMP Requests sent by Spectrum.

 

In this instance, we can see that the device is responding with "noSuchInstance" for very basic things like 1.3.6.1.2.1.1.2.0 = SysObjectId and 1.3.6.1.2.1.1.1.0 = SysDecr.  This is why Spectrum is not able to discover the device as the device cannot respond to basic SNMP requests so that Spectrum cannot further identify the device.

 

Follow up with the vendor to see if the device is not configured correctly for SNMP:

 

 

If any help is needed with reading the wireshark / tcpdump, please open a support case for further assistance.

Additional Information

For Linux the tcpdump command

 

tcpdump -i any -s 0 -w discovery.pcap "host #.#.#.#"

 

Where host #.#.#.# is the ip address of the device you are trying to discover in Spectrum.