Auto Deploy rule management UI in vSphere Client is inaccessible with "Managing rules is temporarily unavailable. An error occurred while connecting to the Auto Deploy service."
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Auto Deploy rule management UI in vSphere Client is inaccessible with "Managing rules is temporarily unavailable. An error occurred while connecting to the Auto Deploy service."

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Article ID: 397966

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to access Auto Deploy > Deploy Rules in vSphere Client, following error message is displayed without any additional information.

"Managing rules is temporarily unavailable. An error occurred while connecting to the Auto Deploy service."

  • Log file /var/log/vmware/vmon/vmon.log will show similar entries to:

    YYYY-MM-DDTHH:MMSS Wa(03)+ host-2393 OSError: [Errno 28] No space left on device
    YYYY-MM-DDTHH:MMSS Wa(03)+ host-2393 OSError: [Errno 28] No space left on device

  • vSphere Appliance Management Interface (VAMI) Monitor > Disk shows /storage/log at 75% full or more:

    At 75% of continuous disk use the space will trigger Yellow status warnings
    At 85% the space will trigger Red critical alarms

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

Potential causes include:

  • vCenter Server log bundles not being cleared after generation.
  • Very high frequency events filling up logs.
  • Services such as the Apache Tomcat Java Servlet service failing to clean up files.
  • /storage/log partition set too small.

Resolution

Resolve /storage/log partition being full on vCenter Appliance by following steps outlined in following article:

vCenter log disk exhaustion or /storage/log full