Manually resolve, acknowledge or suppress alarm on NSX Standby Global Manager
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Manually resolve, acknowledge or suppress alarm on NSX Standby Global Manager

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Article ID: 397854

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You receive alarms on the Standby Global Manager 
  • The Alarm raised may be a stuck alarm that needs to be resolved manually.
  • From the NSX Standby Global Manager UI the option to resolve, acknowledge or suppress the alarm is disabled/greyed out.

Environment

VMware NSX

Cause

This ability to resolve, acknowledge or suppress alarms is disabled on the NSX Standby Global Manager. 

Resolution

This is a condition that may occur in a VMware NSX environment.


Workaround:
Use API call to change the alarm status. This should be implemented once confirming the issue reported by the alarm is resolved. 

List Alarms API call
GET https://<standby-gm-ip>/api/v1/alarms

Resolve Alarm
POST https://<standby-gm-ip>/api/v1/alarms/<alarm-uuid>?action=set_status&new_status=RESOLVED

Acknowledge Alarm
POST https://<standby-gm-ip>/api/v1/alarms/<alarm-uuid>?action=set_status&new_status=ACKNOWLEDGED

Suppress Alarm
POST https://<standby-gm-ip>/api/v1/alarms/<alarm-uuid>?action=set_status&new_status=SUPPRESSED

Additional Information