Service Catalog Offerings Not Displaying in Service Point or Service Catalog
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Service Catalog Offerings Not Displaying in Service Point or Service Catalog

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Article ID: 397775

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Updated On:

Products

CA Service Catalog

Issue/Introduction

When trying to view a Service Catalog Offering in Service Point, the Offering is stuck on loading and generates the following error in the Console Browser:

error: Error: JSONP injected script did not invoke callback. at <SERVICE_POINT_URL>

message: "Http failure response for <SERVICE_CATALOG_URL>

name: "HTTPErrorResponse"

Additionally, the Dashboard in Service Catalog is not loading

Console Browser shows:

Uncaught TypeError: Cannot read properties of null(reading 'documentElement')

 

Finally, when clicking the Catalog tab, there is a pop up saying:

"An error has occurred. Contact the system administrator"

Console Browser shows:

Error: [$http:baddata]

http://errors.angular.js.org/1.8.2/$http/baddata?p0=%!FEF%BF%BD%08%00....

Environment

Service Management 17.4.x

Service Catalog

Service Point

Cause

Apache Tomcat has been manually upgraded past the version provided by Broadcom in 17.4 RU4 (The latest RU patch at the time of this article)

Resolution

Verify the version of Apache Tomcat by opening:

%USM_HOME%\embedded\tomcat\RELEASE-NOTES

In RU4, this is by default:

Apache Tomcat Version 9.0.100

If you see version 102 and higher, there is a compression issue in Tomcat that causes the observed behavior to occur

To resolve this, navigate to:

%USM_HOME%/view/conf/server.xml

And modify the active connector by changing:

compression="on"

to

compression="off"