VxRail section is blank in the vXRail Cluster Configuration on vCenter Server
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VxRail section is blank in the vXRail Cluster Configuration on vCenter Server

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Article ID: 397748

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

  • On vSphere Client, when navigating to VxRail Cluster -> Configure -> VxRail, the page is blank and has no information even though VxRail is configured on the cluster and the plug-in is installed on the vCenter Server.
  • Running the lsdoctor -l option lists duplicate service registrations in the Lookup Service database:
    • Follow the instructions in KB: Using the 'lsdoctor' Tool
    • Use lsdoctor -l option to list the common issues in the lookup service.
    • The output is similar to below:
                 "Duplicates Found": {
                          "Description": "Duplicate Endpoints Detected",
                          "Duplicates by Node ID": {
                              "<Node-ID>": {
                                  "<Service Registration Name>": [
                                      "<Service_ID-1>",
                                      "<Service_ID-2>",
                                  ]
                                                           }

Environment

vCenter Server 8.x

Cause

The Lookup Service database contains duplicate service registrations. When multiple entries exist for the same service ID, the client may fail to resolve a single valid endpoint.

Resolution

Step 1: Find the service ID that is invalid for the reported Service Registration.

  • SSH to the vCenter Server as root -> enter shell.

  • cd  /var/log/firstboot

  • grep -i "Service_ID-1" *

  • grep -i "Service_ID-2" *

  • The command with no output indicates that it is the stale service registration and needs to be removed.

 

Note: Ensure to take valid backup for the vCenter Server or Snapshot for the vCenter Server before proceeding with the steps below. In case of ELM, take offline snapshots for all the vCenter Servers.

Step 2: Remove the duplicate/stale Service ID for the reported Service Registration.

  1. SSH to the vCenter Server as root -> enter shell.

  2. Take a spec backup for the duplicate service ID:
    /usr/lib/vmware-lookupsvc/tools/lstool.py get --url https://localhost/lookupservice/sdk --id <Duplicate-Service-ID> --as-spec --no-check-cert > /var/core/Service_Registration.spec

  3. Run the command below to remove the duplicate service ID:
    /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url https://localhost/lookupservice/sdk --id <Duplicate-Service-ID> --user 'administrator@<SSO_domain_name>' --password '<password>' --no-check-cert

  4. Restart the vCenter Services. In case of ELM, restart the services on all vCenter Servers:
    service-control --stop --all && service-control --start --all