Some NES are unreachable intermittently
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Some NES are unreachable intermittently

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Article ID: 397740

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

A NES becomes unreachable and after some minutes reachable again and after again some minutes unreachable again etc...
Some NES are unreachable intermittently

Environment

Release Automation 6.6

Cause

The network is overloaded by HeatlhCheck messages sent from the NAC to all NES.

The HealthCheck service was completely removed from version 6.6.4 onwards as it was found that it may create unnecessary overhead on the network channels between NAC and NES servers which in a high-loaded environment could result in slowness and affect much more important deployments-related communications.

Resolution

It is possible to disable the checks initiated by the NAC, it can be done from UI.

On NAC version before 6.6.4, do this to disable the Health Monitoring service :

  1. - In Administration menu select Health Monitoring :


    If "Health Monitoring" item does not appear in Administration menu, to in System Settings and set
    Show heath monitor = true :



    And restart the Nolio service on the NAC.


  2. At the top left corner there is a switch after "System monitoring" title, changing it to "Off". This will stop periodic health check initiated by NAC :

Additional Information

From version 6.4 and above, the Health Monitor function is no longer available. To monitor agents and servers, use an application performance management tool.