vSAN Data protection section view is not populating in the vSphere UI followed by a VCenter reboot or Vcenter certificate renewal
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vSAN Data protection section view is not populating in the vSphere UI followed by a VCenter reboot or Vcenter certificate renewal

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Article ID: 397738

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Updated On:

Products

VMware vSAN

Issue/Introduction

In the process of removing a Netapp plugin, vCenter was rebooted.

Since then the vSAN Data protection section view is not populating desired data and following error gets reported.

Issue can also occur if vCenter certificate gets renewed 




In vSAN Data Protection Appliance under storage/log/snapservice/snap-service-ui.log you see messages referring to

{"level":"error","timestamp":"2025-06-17T16:07:41.662Z","C":"auth/client.go:359","message":"Failed to get token from cert/key pair","error":"ns0:FailedAuthentication: Password of the user logging on is expired. :: Password of the user logging on is expired. :: User account expired: {Name: com.vmware.vsan.snapservice, Domain: 

Environment

8.0 U3

Cause

vCenter username/password was missing from compose_snapservice_config.yaml file in Snapshot Service appliance.

/opt/vmware/snapservice/app/deployment/compose_snapservice_config.yaml

 

Resolution

1. Open an SSH session to the Snapshot Service appliance.

 

2. Stop snapservice  by running the command: 

systemctl stop snapservice

 

3. Edit /opt/vmware/snapservice/app/deployment/compose_snapservice_config.yaml and fill in the vCenter username/password.


If the domain name is not default vsphere.local, please update it as well.
Please also verify and confirm the VC and appliance addresses.

Please see a sample output below:

vsphereConfig:
useMockServer: false
vcenter: <vCenter FQDN> 
username: ""
password: ""
sslVerify: true
appliance: <vCenter FQDN> 
svcAccountCredentialPath: /secrets/svc_account_credential
domainName: vsphere.local

 

4. Start the snapservice  by running the command:

systemctl start snapservice