UIM data_engine does not start and it fails connecting to SQL
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UIM data_engine does not start and it fails connecting to SQL

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Article ID: 397700

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After changing the database provider to MSOLEDBSQL, the UIM data_engine probe does not start.

In the \Nimsoft\probes\slm\data_engine\data_engine.log we find the following error:

May 15 13:55:10:779 [14972] 0 de: COM Error [0x800a0e7a] Unknown error 0x800A0E7A - [ADODB.Connection] Provider cannot be found. It may not be properly installed.

Environment

UIM 23.4.4

Cause

This was occurring because a SQL Server odbc driver is missing on the server.

Resolution

You can check if the driver is installed by doing the following:

  1. Open your 'Administrative Tool' gui.
  2. Open the 'ODBC Data Source (64 bit)' icon.
  3. Select the 'Drivers' tab.
  4. Check to see that the 'SQL Server' is listed.

     
  5. If the driver is missing you can manually run the msoledbsql.msi install.

It should be in the following folder where your UIM server was installed: Nimsoft\install\setup\win\MSOLEDBSQL\msoledbsql.msi