Error "A problem occurred while getting data from the source vCenter server" is encountered when upgrading the vCenter Server Appliance
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Error "A problem occurred while getting data from the source vCenter server" is encountered when upgrading the vCenter Server Appliance

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Article ID: 397606

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Updated On: 05-14-2025

Products

VMware vCenter Server

Issue/Introduction

While attempting to upgrade the vCenter Server Appliance, the process fails at Stage 1 - Step 3 (Connect to source appliance) with the error:

"A problem occurred while getting data from the source vCenter server."

The installer.log on the jump server — from which the VCSA UI installer is launched — confirms that the connection to the ESXi host (hosting the source vCenter Server VM) over port 443 is failing.

%temp% /vcsauiinstaller/installer.log

[YYYY-MM-DDTHH:MM:SS] - error: Could not get response for get request from url https://esxi_hostname:443/guestFile?id=5&token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx: Error: connect ETIMEDOUT IP_address:443
[YYYY-MM-DDTHH:MM:SS] - error: Failed to get data from url:https://esxi_hostname:443/guestFile?id=5&token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx, error: Could not get response for get request from url https://esxi_hostname:443/guestFile?id=5&token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx: Error: connect ETIMEDOUT IP_address:443
[YYYY-MM-DDTHH:MM:SS] - error: Error in getting fileData for nodeType. Error: "Could not get response for get request from url https://esxi_hostname:443/guestFile?id=5&token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx: Error: connect ETIMEDOUT IP_address:443

 

 

Environment

VMware vCenter Server Appliance

Cause

Port 443 is not open or accessible on the source ESXi host where the vCenter Server Appliance to be upgraded resides. The upgrade process requires an HTTPS connection to the source ESXi host to verify the readiness of the source appliance and to establish an SSH connection between the new and existing appliances.

Resolution

This appears to be an environmental network issue.

Investigate further with networking and firewall teams to identify any factors that may be blocking communication over port 443 between the deployment jumpbox and the ESXi host where the source vCenter Server Appliance resides.
This includes checking for any default application-level firewall settings on the jumpbox VM that might restrict outbound connections.

Workaround:
Run the vCenter installer ISO from a jumpbox that resides on the same ESXi host as the destination vCenter VM.

Additional Information