Getting error while viewing Disk Management for vSAN host "Unable to extract data. Check vSphere Client logs for details" through vCenter UI
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Getting error while viewing Disk Management for vSAN host "Unable to extract data. Check vSphere Client logs for details" through vCenter UI

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Article ID: 397584

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Updated On:

Products

VMware vSAN

Issue/Introduction

Three of the nodes in 4-node vSAN cluster shows an error under the disk management menu, which displays as "Unable to extract data. Check vSphere Client logs for details".

  • Issue can be observed from vCenter client for few or more host.
  • vSAN Disk and disk group can be managed from command line.

Environment

vSAN OSA, ESXi 8.0.3 Build: 24414501

VMware vCenter Server Version: 8.0.3 Build: 24322831

 

Cause

This is a known issue from the vCenter and ESXi level and is expected to be resolved in future release.

 

Resolution

No resolution yet, but the fix is scheduled to be included in the next patch release of the 8.0 series (8.0 P06). vSAN disk and disk group can still be managed from command line.

Please find the below KB, which provides more information to manually manage and configure a vSAN disk group using esxcli commands using command line.

CLI KB - 315532

Additional Information