Error : 550 5.7.51 Service unavailable, Client host(IP address) blocked using Customer Block list AS(1420) in Email Security Cloud
book
Article ID: 397521
calendar_today
Updated On:
Products
Email Security.cloud
Issue/Introduction
Track and Trace displays an error message "550 5.7.1 Service unavailable, Client host [IP address] blocked using Customer Block list AS(1420)
Environment
Email Security.cloud
Cause
The Track and Trace logs shows an error stating "550 5.7.1 Service unavailable, Client host [IP address] blocked using Customer Block list AS(1420).
This is a Microsoft rejection error code.
Resolution
This error indicates that the sender's IP address has been blocked by the recipient's email service provider, likely Microsoft 365.
Please contact the recipient's admin to delist the sender's IP address from their block list to allow email messages to be delivered from the sending domain.