SRM Adapter Instance Fails with "Method drextapi.ServiceInstance.login threw undeclared fault of type drextapi.fault.ConnectionDownFault" Error in Aria Operations
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SRM Adapter Instance Fails with "Method drextapi.ServiceInstance.login threw undeclared fault of type drextapi.fault.ConnectionDownFault" Error in Aria Operations

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Article ID: 397460

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Certain SRM adapter instances fail to connect with the SRM server. The following error can be seen for the SRM adapter accounts:

    • Method drextapi.ServiceInstance.login threw undeclared fault of type drextapi.fault.ConnectionDownFault

  • The /storage/vcops/log/collector.log event shows the following:

    • 2025-04-28T02:17:39,693+0000 WARN [Collector worker thread 23] com.vmware.srm.vrops.SrmAdapter.onCollect - Failed to create authenticated srm factory com.vmware.vim.binding.vmodl.fault.SystemError: Method drextapi.ServiceInstance.login threw undeclared fault of type drextapi.fault.ConnectionDownFault

Environment

  • Aria Operations 8.x

Cause

  • The error ConnectionDownFault indicates a failure in establishing a network connection between the Aria Operations Collector and the SRM server. Possible reasons include:

    • Network connectivity issues (firewall, port block, routing)

    • Transient disruptions in network or SRM service availability

Resolution

  • Verify the status of the SRM service on both sites.

  • Ensure that port 443 (HTTPS) is open, as required by the VMware Aria Operations Management Pack for VMware Live Site Recovery.

  • Verify network connectivity (ping, telnet) between SRM servers and between SRM and Aria Operations collector group nodes.

  • Verify and confirm the vCenter and SRM adapter credentials in Aria Operations.

  • Update or re-register the SRM Management Pack if the integration appears to be broken.

  • If a different collector node (CP) meets the necessary network requirements, move the impacted SRM adapter accounts to that CP/Collector.

    • Move the impacted SRM adapter accounts to a different collector (CP) and click on Validate connection — the test should succeed.

 

  • After successful validation on alternate collectors, move the adapter accounts back to their original Collectors and Validate the connection again — it should now succeed.

  • If issue recurs, check for intermittent network drops, SRM availability, or firewall rules between the Collector and SRM server (port 443).

    • Review logs: /storage/vcops/log/collector.log and /storage/vcops/log/adapters/SrmAdapter/SrmAdapter_InternalId.log

Additional Information

  • The issue may manifest after applying an Aria Operations hotfix, patch or an upgrade.

  • The Aria Operations Management Pack for SRM can provide additional monitoring and alerting for SRM connectivity and health.