Integration from Catalog to SDM is not working when using a Load Balancer URL
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Integration from Catalog to SDM is not working when using a Load Balancer URL

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Article ID: 397435

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

The following error occurs when testing the SDM integration from Catalog server.

Service Catalog\logs\view.log:

TRACE [Configuration] In queryConfigurationObjects for domain/groupName : INSTALLED_DEFAULT/servicedesk
TRACE [AbstractWebserviceManager] WS URL Full Address = https://<Load Balancer URL to SDM>:<LB Port>/axis/services/USD_R11_WebService
TRACE [AbstractWebserviceManager] WS Class Name= com.ca.usm.webservices.ServiceDeskWebserviceManager
TRACE [AbstractWebserviceManager] pki:CASM_POLICY:<Service Catalog Home>\CASM_POLICY.p12:<Admin user>:3:15
TRACE [ServiceDeskWebserviceManager] begin:loginMethodPki
ERROR  [ServiceDeskWebserviceManager] Error while connecting to Service Desk: javax.xml.ws.WebServiceException: Could not send Message.
....
ERROR [CConfiguration] CCONF.TESTCONF.EXCPT
com.ca.usm.webservices.WebserviceException: Could not send Message.

Environment

Service Desk Manager 17.4 - SSL is configured only at the Load Balancer level. Tomcat is not configured with SSL.

Service Catalog 17.4 

Load Balancer URL for Service Desk Manager.

Cause

This approach worked OK in previous versions. However, with the new changes related to the migration from Axis to CXF, the new CXF client will use the endpoint from the WSDL file for further communication. As long as the WSDL has a correct URL with HTTPS, then integration will work smoothly.

Resolution

1. Enable HTTPS/SSL in Tomcat in the SDM Server(s) where WebServices are running.

2. Configure the Load Balancer setting to point from HTTP to HTTPS for the SDM Tomcat Web Services. This configuration will be different based on the type of Load Balancer.

Additional Information