DPS NetGuardian G5 device fails to show support for the DPS certifications
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DPS NetGuardian G5 device fails to show support for the DPS certifications

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Article ID: 397404

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

We recently upgraded our DEV environment to 24.3.8 which includes certifications of NetGuardian G5 devices. 

Post the upgrade we discovered couple of G5 devices in our DEV environment but we are not able to see the components getting discovered in Performance Management which were included in the certification request. 

We need some help in modelling these NetGuardian devices correctly in PM and monitor the certified components for performance metrics.

Newly discovered G5 where metric family (Environmental Sensor - Generic) says unsupported:

When trying to run a MIB dump against the device we see errors like the following from the NetGuardian enterprise specific MIB OIDs. We see it reach the end of the public MIB, try to query the vendor specific proprietary OIDs, and get a bad response from the device.

1.3.6.1.6.3.15.1.2.1.0        , Counter     , 1
1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#ERROR:LEXORDER:1.3.6.1.4.1.2682.1.2.1.1.0    , OctetString , DPS Telecom
#ERROR:LEXORDER:1.3.6.1.4.1.2682.1.2.1.2.0    , OctetString , NetGuardian832-G5
#ERROR:LEXORDER:1.3.6.1.4.1.2682.1.2.1.3.0    , OctetString , v5.5I

We then see the dump end with further errors indicating device problems.

#ERROR:LEXORDER:1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#Agent is broken. Getnext returned request oid. Trying 1.3.6.1.6.3.15.1.2.2
#ERROR:LEXORDER:1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#Agent is broken. Getnext returned request oid. Trying 1.3.6.1.6.3.15.1.3
#ERROR:LEXORDER:1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#Agent is broken. Getnext returned request oid. Trying 1.3.6.1.6.3.15.2
#ERROR:LEXORDER:1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#Agent is broken. Getnext returned request oid. Trying 1.3.6.1.6.3.16
#ERROR:LEXORDER:1.3.6.1.6.3.16.1.5.1          , Counter     , 1
#Agent is broken. Getnext returned request oid. Trying 1.3.6.1.6.4
#Walk ended

Environment

All supported Network Observability DX NetOps Performance Management releases

Cause

Device firmware defects

Resolution

According to NetGuardian G5 vendor support the v5.5I firmware version is the cause of the problem. They state the following.

This issue is something that has been resolved in later firmware versions. It appears that this walk came from a G5 on version 5.5I, but I'd recommend upgrading to the latest version (5.6I) to resolve this issue. I tested just to be sure and found I can replicate this issue on version 5.5I and this issue is no longer present on the latest version. If you have any follow up questions on the matter, let us know. 

Upgrade the device firmware to resolve the issue. After upgrading the device firmware running Update Metric Family against the "Environmental Sensor - Generic" MF for the device(s) will resolve the issue.