Zerto Failover Fails due to SRM Tag Presense
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Zerto Failover Fails due to SRM Tag Presense

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Article ID: 397398

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Updated On:

Products

VMware vCenter Server VMware Live Recovery VMware Site Recovery Manager 8.x

Issue/Introduction

Zerto based failover cannot complete due to the following errors seen from the Zerto appliance:

log.20857.csv:4adc54d4,cc3c2fd8,17106790,,2025-05-01 19:05:49.53+00:00,E,152,VSphereTaggingService,AssignTagsToVM,Error occurred,"System.ArgumentException Void ThrowAddingDuplicateWithKeyArgumentException[T](T) System.ArgumentException: An item with the same key has already been added. Key: SRM-com.vmware.vcDr:::status
log.20409.csv:4adc54d4,bbec5d1e,16805791,,2025-04-29 12:23:21.03+00:00,E,165,VSphereTaggingService,AssignTagsToVM,Error occurred,"System.ArgumentException Void ThrowAddingDuplicateWithKeyArgumentExceptionT System.ArgumentException: An item with the same key has already been added. Key: SRM-com.vmware.vcDr:::consistencyGroup

Environment

VMware Live Recovery 9.0 +

Site Recovery Manager 8.8
Site Recovery Manager 8.7
Site Recovery Manager 8.6

Cause

Improper decommissioning of the Site Recovery Manager appliance:

If Site Recovery Manager is not decommissioned properly, then the SRM Tags and Site Recovery Plug-in will be left over in the vCenter inventory.

According to Zerto, their failovers will not complete if these SRM tags are present.

Resolution

Only proceed if the Site Recovery Manager appliance is no longer configured in the vCenter or in use, go ahead and manually remove the SRM Tags:

  • Log into the vSphere Client
  • Click on the menu button
  • Click on Administration
  • Click on Tags & Custom Attributes
  • Click on Categories
  • Filter the 'Category Name' with 'SRM'
  • Highlight and Remove all 6 SRM Categories:
      • Note: Each category has a number of tags associated, it is safe to remove all tags associated in the category.