Error "Unable to get vRA access token via existing refresh token" in Aria Automation Custom Form
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Error "Unable to get vRA access token via existing refresh token" in Aria Automation Custom Form

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Article ID: 397295

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Updated On: 05-12-2025

Products

VMware Aria Suite

Issue/Introduction

  • Unable to deploy virtual machines from the Aria Automation catalog

  • Upon clicking the "Request" button, or after selecting the OS Type in the custom form, an error message appears indicating "Unable to get vRA access token via existing refresh token" with a "400 Bad Request" status and "Invalid refresh token" as shown below:

    • Action 'getFlavors' in module 'com.########.###.#####.#######.####.vro.actions.presentation' failed : Error: Unable to get vRA access token via existing refresh token: {"status":400,"headers":{"expires":"0","date":"Thu, 24 Apr 2025 09:46:36 GMT","server":"envoy","x-envoy-upstream-service-time":"364","x-frame-options":"DENY","content-length":"291","vary":"Origin,Access-Control-Request-Method,Access-Control-Request-Headers, Accept-Encoding","pragma":"no-cache","cache-control":"no-cache, no-store, max-age=0, must-revalidate","referrer-policy":"no-referrer","x-xss-protection":"0","strict-transport-security":"max-age=31536000 ; includeSubDomains","content-type":"application/json","x-content-type-options":"nosniff"},"body":{"timestamp":1745487997006,"type":"CLIENT_ERROR","status":"400 BAD_REQUEST","error":"Bad Request","serverMessage":"REST error received: {\n \"error\": \"invalid_grant\",\n \"error_description\": \"Invalid refresh token: ################################\"\n}, status code: 400 BAD_REQUEST"}}. (Dynamic Script Module name : AuthClientService#99); [2][flavor.valueList][com.########.###.#####.#######.####.vro.actions.presentation/getFlavors] undefined;

  • This issue prevents successful VM provisioning

Environment

  • VMware Aria Automation 8.18.x

  • VMware Aria Automation 8.x

Cause

  • The error is caused by an expired or invalid refresh token used to obtain the Aria Automation access token within Aria Orchestrator actions/workflows

  • This prevents the Aria Orchestrator Actions/Workflows from successfully retrieving necessary information (like flavors and images) during the VM deployment request

Resolution

To resolve this issue, a new valid refresh token needs to be obtained and updated in the configuration section of Aria Orchestrator. Follow these steps:

  • Run this command to obtain the refresh token

curl --insecure -H "Accept: application/json" -H 'Content-Type: application/json' --data '{"username":"<username>","password":"<password>"}' https://<vra-host>/csp/gateway/am/api/login?access_token

  • Access Aria Orchestrator --> Assets --> Configurations and look for the configuration that is utilized by Aria Automation

Note: This configuration is used internally by the Orchestrator workflows/actions to deploy Cloud Templates

  • Edit the variable refresh token and update the refresh token that is obtained in step 1

  • Rerun the Workflow/Provisioning/Catalog

Additional Information

  • Refresh tokens have a limited lifespan (a Refresh Token is valid for 90 days and an Access Token times out after 25 minutes of inactivity) and will eventually expire, requiring the generation of a new token. It is recommended to periodically review and refresh these tokens to prevent service disruptions

  • If the issue persists after updating the refresh token, further investigation of the custom Aria Orchestrator Action/Workflow logic by the PSCOE team may be necessary to identify any other potential authentication or configuration issues