SDDC Manager workload domain fails with License check: "failed to fetch licenses from vCenter ########## as its license service may be down"
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SDDC Manager workload domain fails with License check: "failed to fetch licenses from vCenter ########## as its license service may be down"

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Article ID: 397294

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • Issue with fetching the vCenter license for workload domain in sddc manager pops out with the  message "License check: failed to fetch licenses from vCenter ############ as its license service may be down"

 

  • Individual component will error out on license status as below

....

 

Environment

VMware SDDC Manager 5.2.x

Cause

This issue will occur when the Domain ID value used in the API mismatches with the PSC name retrieved  through API resulting in fetching wrong PSC name to connect to fetch the license and eventually authentication will fail.

Resolution

The reported issue is fixed in SDDC 9.0.0.0.


For lower versions (5.x), please try the below workaround steps so the master PSC (######) in the ELM ring comes in the top of the list and issue will resolve:

Workaround:

  1. SSH to sddc manager.

  2. Login to postgres DB on SDDC Manager.

    psql -U postgres -h localhost

  3. Connect to Platform Database.

    \c platform;

  4. Run the below DB queries for fetching vCenter and PSC details.

    select * from vcenter; (This query will list the vCenter part of the workload domain)

    select * from psc; ( This will list the psc)

        Example: The below screenshot shows the RECORD1 and RECORD2 from PSC list, For making RECORD2(management vCenter ) on top of the PSC list we will increase the modification time of RECORD2 by "+1" (Ex: From 1728354475382 to 1728354475383).

 

    5. Make sure to change the modification time on the management vCenter so that it will appear on top on the PSC list.

        Update modification time for <vCenter name> (update psc set modification_time='<modification time value fetched from step 4 >' where id = '<entity ID of the vCenter fetched from step 4>';)    

 

    6. Ensure the management vcenter entry is listed on top and reload the UI to see if the issue disappears.

        select * from psc;