SNOW VMware Aria Automation Plugin Errors - Missing Roles Due to Demo Data Import Issue
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SNOW VMware Aria Automation Plugin Errors - Missing Roles Due to Demo Data Import Issue

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Article ID: 397201

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • During the installation of the VMware Aria Automation plugin for ServiceNow (SNOW), you may encounter issues configuring the integration because roles are not found in ServiceNow.
  • You may have skipped the Demo data import option.

Environment

VMware Aria Automation 8.x

 

Cause

The demo data, which is crucial for importing groups, table records, scheduled jobs, and system properties, was not selected during the initial plugin installation. This resulted in missing roles and configurations in ServiceNow.

Resolution

Prerequisites

  • You must back up all VMware Aria Automation or Orchestrator appliances, at the same time - simultaneously for all nodes. 
    • If you are making the snapshots manually, you must start the snapshots of the second and the third node not more than 40 seconds after you start the snapshots for the first node.
      • If the quiesced state was not achieved for all 3 nodes within the ~40 seconds time frame, the following strings will be found in the logs: "Freeze synchronization failed" and "Sync failed, making inconsistent snapshot".
      • Run the following command from one of the nodes to filter for all vmtoolsd messages: journal ctl --identifier=vmtoolsd.
      • When you back up the VMware Aria Automation or Orchestrator appliance, disable in-memory snapshots and enable quiescing.

Procedure

  1. Uninstall the VMware Aria Automation plugin from ServiceNow.
  2. Reinstall the plugin, ensuring that the demo data checkbox is selected during installation.
  3. After reinstalling, verify that the roles and required configurations have been properly imported into ServiceNow.