Scheduled Catalog Sync not working but manual Catalog Sync works
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Scheduled Catalog Sync not working but manual Catalog Sync works

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Article ID: 397188

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Catalog Sync that is scheduled for a particular date/time is not updating Catalog items. When we manually run a sync it works without issue. 

Environment

VMware Cloud Director 10.6

Cause

This is due to the LastSyncJob not running on the Cloud Director cell. 

 

 

Resolution

We first check to see if the job is running by using the command below on all vCD cells to find where the jobs are running.

/opt/vmware/vcloud-director/bin/cell-management-tool cell -i $(service vmware-vcd pid cell) -tt | grep "Next Start Time\|LibrarySyncJob"

If the job is running correctly we should see a similar output to the below on one of the nodes.

| UUID                                 | Previous Start Time     | Next Start Time         | Status          | Job Name                                    |
| 0149c13f-a5c6-5c25-b8c5-96a4c58772ab | 2025-03-28 20:00:00.225 | 2025-04-27 20:00:00.000 | STATUS_QUEUED   | LibrarySyncJob  

If the job is not running we need to do the following steps:

  1. Stop the Cloud Director (VCD) services on all Cells:


NOTE: Stopping the VCD services on the Cells can impact the availability of the Cloud Director UI.
     

/opt/vmware/vcloud-director/bin/cell-management-tool -u administrator cell -s


 
**if this does not work simply use:

systemctl stop vmware-vcd.service

 

     2. Start the VCD services on one Cell and ensure the syncing service is present before starting the service on all other Cells.

 

systemctl start vmware-vcd.service


 

/opt/vmware/vcloud-director/bin/cell-management-tool cell -i $(service vmware-vcd pid cell) -tt | grep "Next Start Time\|LibrarySyncJob"

 

     3. If restarting the VCD services on all the Cells does not resolve the issue, please contact Broadcom Support and note this Article ID (397188) in the problem description. For more information, see Creating and managing Broadcom support cases.