Unable to vMotion a VM due to the error "NSX port group not found, which is inaccessible."
search cancel

Unable to vMotion a VM due to the error "NSX port group not found, which is inaccessible."

book

Article ID: 397137

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware NSX

Issue/Introduction

  • During VM vMotion between the hosts within the cluster, a warning was reported in the 'Select Networks' section
    • 'Currently connected network interface – Network adapter X is uses network 'DVSwitch[DVS-ID] NSX port group [dvportgroup-xxxxx] (NSX port group not found)', which is inaccessible

         

  • When we try to browse for the same NSX segments/port groups at destination ESXi host, Its not available
  • This issue would report due to the unavailability of NSX segments/port groups at particular destination ESXi host/transport node within the cluster

Environment

VMware NSX
VMware vSphere ESXi

Cause

This is caused due to missing VLAN transport Zone on Transport node.

Resolution

To resolve the issue, add missing VLAN transport zone on the each problematic ESXi transport node and retry the vMotion.

  1. Login to NSX UI. Go to System > Fabric > Hosts
  2. Select the individual host > Edit to click on "manage Transport Zones" option--> Add missing transport zone under transport Zone section--> Click on "Save"
  3. It will take couple of minutes to complete

 

 

Additional Information

If the above solution doesn't fix the issue, we recommend reaching out to Broadcom support by creating a support case using the instructions at Creating and managing Broadcom support cases.