Identity Portal cannot be accessed after database failover
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Identity Portal cannot be accessed after database failover

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Article ID: 397119

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Identity Portal getting  the following error after database failedover during DR process

2025-04-26 09:39:26,281 ERROR [io.undertow.request] (default task-4232) UT005023: Exception handling request to /sigma/rest/public/available: javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: could not extract ResultSet
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Caused by: org.hibernate.exception.GenericJDBCException: could not extract ResultSet
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Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The connection is broken and recovery is not possible. The connection is marked by the client driver as unrecoverable. No attempt was made to restore the connection.
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2025-04-26 09:39:27,578 WARN  [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (default task-4230) SQL Error: 0, SQLState: null
2025-04-26 09:39:28,703 ERROR [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (default task-4230) The connection is broken and recovery is not possible. The client driver marks the connection as unrecoverable. No attempt was made to restore the connection.

Environment

Identity Portal 14.5

Cause

The connection state has changed in the application server

Resolution

Restart Identity Manager and Identity Portal