Unable to install standalone workflow component using custom web site.
search cancel

Unable to install standalone workflow component using custom web site.

book

Article ID: 397062

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Installation using custom website fails on ASP readiness check

ASP.NET may be prohibited in your IIS configuration. Please check IIS web service extensions and ensure that ASP.NET is Allowed.

Choosing default web site is successful.

You attempted changes such as:

  • SSL/HTTP only
  • HTTP only using port 80 on custom web site (initially was using 8080)
  • Changing default app.pool to handle custom web site and common changes such as classic/integrated pipeline and identity changes

Environment

ITMS 8.7.3

Cause

Known issue.

What happens behind the scenes?

WF Service (Logicbase Server extenstions) manages self-configuration in folder "C:\Program Files\Symantec\Workflow\Data\MQConfig" in .lbemsg2 files

 

The contents is encrypted by the Encryption Key file. Filename is specified in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TransparentLogic.com\WorkflowServer\keyFileName  (default location of storage is c:\program data\Symantec\Workflow\<filename>

When WF uninstall occurs, it deletes both the registry and the encryption key file. However it DOES NOT delete "C:\Program Files\Symantec\Workflow\Data\MQConfig" folder with the encrypted config files.

Then, when WF Install occurs again a new encryption key file is generated.

When WF Services starts up, it tries to  decrypt stuff in lbemsg files and fails (no suitable decryption key). 

This failure leads to NOT INITIALIZE certain .NET remoting channel during service Startup phase.

After WF Server component is installed, the WF installer uses remoting to get some settings, but remoting channel does not exist - this is exactly what exception "System.Runtime.Remoting.RemotingException: Failed to write to an IPC Port: The pipe is being closed" says.

Resolution

This issue has been fixed with our ITMS 8.8 Release.

For those with ITMS 8.7.3 release, refer to the pointfix available at CUMULATIVE POST ITMS 8.7.3 POINT FIXES:

Workaround:

  1. Since Uninstall assumes major cleanup, I believe it is legal to rename the C:\Program Files\Symantec\Workflow\Data  folder  BEFORE 2nd installation attempt. That way the installed WF service will not try to decrypt old data with new key.
  2. Another possible solution would be to REIMPORT the saved encryption key (if it was explicitly saved during the 1st install) during 2nd install - during this phase in the wizard.