Slow Performance when executing Recovery Plan Test using Site Recovery Manager
search cancel

Slow Performance when executing Recovery Plan Test using Site Recovery Manager

book

Article ID: 397042

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

When running a Recovery Plan Test, the completion time takes a significantly more time to complete than before:

Environment

Live Site Recovery 9.0 +
Site Recovery Manager 8.6 +

Cause

Each ESXi host took ~ 5 minutes to rescan its HBAs, causing the Recovery Plan to take longer than expected.

The vmware-dr.log file in the /var/log/vmware/srm/ directory will show information regarding the Recovery Plan Test:

Here we see the ESXi hosts failing to rescan their HBAs:

2025-05-01T10:06:59.087-05:00 error vmware-dr[1309853] [SRM@6876 sub=AbrRecoveryEngine opID=xxx-xxx-xxx-xxx] Failed to rescan HBAs on host 'host-xxxx:ESXi-FQDN':

2025-05-01T10:06:59.087-05:00 error vmware-dr[1309853] [SRM@6876 sub=AbrRecoveryEngine opID=xxx-xxx-xxx-xxx] Failed to rescan HBAs on host 'host-xxxx:ESXi-FQDN':

2025-05-01T10:06:59.087-05:00 error vmware-dr[1309853] [SRM@6876 sub=AbrRecoveryEngine opID=xxx-xxx-xxx-xxx] Failed to rescan HBAs on host 'host-xxxx:ESXi-FQDN':

2025-05-01T10:06:59.087-05:00 error vmware-dr[1309853] [SRM@6876 sub=AbrRecoveryEngine opID=xxx-xxx-xxx-xxx] Failed to rescan HBAs on host 'host-xxxx:ESXi-FQDN':

2025-05-01T10:06:59.087-05:00 error vmware-dr[1309853] [SRM@6876 sub=AbrRecoveryEngine opID=xxx-xxx-xxx-xxx] Failed to rescan HBAs on host 'host-xxxx:ESXi-FQDN':

Below, you see hosts report how long the HBA took to rescan:

2025-05-01T10:27:07.069-05:00 verbose vmware-dr[1309801] [SRM@6876 sub=PerformanceMonitor opID=xxx-xxx-xxxx-xxxx-xxx-test] Completed RescanHost. 'host-xxxxx' took 5.27789 seconds

2025-05-01T10:32:01.807-05:00 verbose vmware-dr[1306173] [SRM@6876 sub=PerformanceMonitor opID=xxxx-xxxx-xxx-xxx-xxx-test] Completed RescanHost. 'host-xxxxx' took 00:05:00.016576 (hh:mm:ss.us)

Resolution

  • Reboot each ESXi host one by one in the cluster: 
    • Rebooting the ESXi hosts resets all HBAs and allows them to rescan in a more effective manner

  • Run the Recovery Plan Test again.

  • If the Recovery Plan Test continues to take a long time, open a case with the Broadcom Storage team to investigate potential storage related issues on the ESXi host(s)