UI View doesn't show data points when data is to close to zero
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UI View doesn't show data points when data is to close to zero

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Article ID: 397037

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Missing metrics on an interface
 
There are missing utilization numbers. Both the in/out high speed counters are incrementing. The SNMP index of the interface is 1610900289 - I didn't filter the DC debug logging to the specific interface, just the IP. I can see it calculating deltas on both the in/out counters but the charts don't reflect that, also showing 0 bps on both in/out when the utilization data is missing.
 
 
Polling debug shows data is returned for DB insertion.
 
Data Aggregator Odata data exports show valid data. This is a sample.
 
Timestamp    im_UtilizationIn    im_UtilizationOut    im_Utilization
Your time zone: Wednesday, May 7, 2025 11:20:00 AM GMT-04:00 DST; 1746631200    1.02E-05    9.75E-06    1.02E-05
Your time zone: Wednesday, May 7, 2025 11:25:00 AM GMT-04:00 DST; 1746631500    1.03E-05    9.82E-06    1.03E-05
Your time zone: Wednesday, May 7, 2025 11:30:00 AM GMT-04:00 DST; 1746631800    1.03E-05    9.82E-06    1.03E-05
 
Report exports in PDF or CSV from the problem View in the UI also show no data. We see the expected poll time entries, but all but the one data point from the View are listed. All others are empty of values. No zero's or NULL references.

Environment

All supported Network Observability DX NetOps Performance Management releases

Cause

The polled data for the interface is so low, the value is so close to zero, when seen alongside the lone >0 value with a 'normal' value, causes scaling problems in the UI View.

Resolution

DE170337 was submitted to resolve this. It will set things to see data like this and create it as a zero in Portal UI Views.

The raw real data values, those barely >0, would still be available in the DA Odata exports.

The resolution for DE170337 is currently targeted for DX Netops ######.

Note that this is subject to change, and there are no release dates I can provide at this time.

There is a list of fixed issues in the documentation which is updated with each release.

You can sign up for notifications in your support account to be notified when new DX Netops releases are available:

https://knowledge.broadcom.com/external/article?articleNumber=253151