OpenSearch service not starting on vIDM Nodes and one of the node 8443 GUI not loading.
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OpenSearch service not starting on vIDM Nodes and one of the node 8443 GUI not loading.

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Article ID: 396988

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

One of the vIDM node not loading on vIDM LB UI dashboard and for that node 8443 GUI page is not loading.

OpenSearch of the node is not starting.

 

Environment

VMware Identity Manager 3.3.x

Cause

This may occur when the Idm-cacerts is corrupted on specific node. 

 

Resolution

Workaround:


Before following the steps below, make sure to take a snapshot of the virtual appliance(s)

  1. SSH to VMware Identity Manager Appliance(s) using root credentials. Change the directory to the location /usr/local/horizon/conf  and check  Idm-cacert file is this blank or not.

  2. Check non-working vIDM Node if Idm-cacert is blank/corrupted.  
  3. If the file is  blank/corrupted then Back up the current file by running the command:

    mv Idm-cacert Idm-cacert.backup

  4.  Then copy the file from working node to non-working node with following command

    scp  Idm-cacert <root@vidm-node>:/usr/local/horizon/conf/

  5. Verify on non-working vIDM Node if Idm-cacert is copied correctly

  6. Change the owner of the Idm-cacert to horizon:www and change the permission of the file by running the command:

    chown horizon:www Idm-cacert 
    chmod 777  Idm-cacert 

  7. Start vIDM/Workspace service by running the command:
    service horizon-workspace start

  8. Start OpenSearch service by running the command:
    /etc/init.d/opensearch start

 

 

Additional Information

The  Idm-cacert has been corrupted and needs to be restored. 

Ran inventory Sync from Area lifecycle Manager for vIDM