Remote Agent is stuck in a Stopped status
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Remote Agent is stuck in a Stopped status

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Article ID: 396913

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After pointing a Remote Agent from one master to another master and restarting the Agent, the Agent goes from a No_Service or Srvc_Down status to a Stopped status.

However, attempting to put the Agent in a Running status from the Java Client or from the command line does not work and no errors are seen in the Agent logs.

Communications and actions such as "Agent Log Rollover" works indicating that the Agent is connected to the master.

Environment

Applications Manager 9.x

Cause

Communication to previous master may still be in place

Resolution

  1. In the Java Client, selecting options View > View Connections > Rmi Servers tab.

    In the last column is the column Master with 2 or more rows with the value OK.

    For each OK value, review the IP address (RmiServer's IP) column to determine if it belongs to the current RmiServer IP or if it belongs to an older RmiServer IP.

    For each row that has an OK value AND an old RmiServer IP, double click on the cell with the OK value. A prompt to "Disallow this RmiServer from being the Automation Engine" will be seen. Select OK and the value will change to a No.

    Do this until there is only one row with an OK value which has the current RmiServer IP value in the IP Address column.

  2. Stop both the Master and the Remote Agent.

    Before restarting the Master and the Remote Agent, delete the contents of the AW_HOME/status and AW_HOME/pipe directories.

    Restart both Master and Agent.