Aria Operations upgrade stuck for a long period of time on step 10 with no Error showing in VMware Lifecycle Manager (LCM). However, cluster is showing upgrade completion. Cluster is online and is on the latest release.
Environment
VMware Aria Suite Lifecycle 8.18.x
Cause
There are a few potential causes:
Some instances of Cloud Proxy are stuck on upgrade and is timing out.
There are other product upgrade events in progress, causing delay on the inventory update and upgrade completion.
Resolution
Log into Aria Operations Admin UI.
Validate the upgrade is showing as completed.
Validate cluster version is on the upgraded release.
Validate Cluster is Online.
Validate Cloud Proxies are all upgraded to latest release, if any.
Once the above has been confirmed, log into LCM UI.