Unable to pair Site Recovery Manager appliance with peer vCenter
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Unable to pair Site Recovery Manager appliance with peer vCenter

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Article ID: 396904

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

You are unable to perform a new site pairing in SRM/VLSR and are receiving errors when trying to find the peer vCenter server on step 2.

"Unable to acquire token from SSO server at 'https://vcfqdn/sso-adminserver/sdk/vsphere.local'."

Environment

VMware Live Recovery 9.X

Cause

This issue is occurring due to issues with the SRM appliance attempting to contact the target vCenter appliance.

/opt/vmware/support/logs/dr-client/dr.log will show the following errors complaining about network routing to the target vCenter:

  • "com.vmware.srm.client.topology.impl.vmomi.TokenProvider$AcquireTokenFailed: Unable to acquire token from SSO Server at 'https:/xxxxxxxxxxxx/sso-adminserver/sdk/vsphere.local'."
  • "No route to host: targetvcfqdn"

Resolution

Ensure network connectivity between Site Recovery Manager and target vCenter server over port 443.

  • Perform an nslookup from the SRM appliance SSH session to the target vCenter server using FQDN and then a reverse lookup using IP address
  • Perform a curl test from the SRM appliance ssh session to the target vCenter server to verify port 443 is open
  • Ensure there are no issues with time drift between appliances

Additional Information