The Siteminder AdminUI returns "Unable to Process Logins"
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The Siteminder AdminUI returns "Unable to Process Logins"

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Article ID: 396901

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Updated On:

Products

SITEMINDER

Issue/Introduction

A Siteminder Admin may get the following error when attempting to log on to the Siteminder AdminUI.

"Unable to Process Logins"

Typically, stopping and starting the AdminUI will resolve this issue.  In extreme cases, restarting the AdminUI doesn't resolve this condition.

Environment

PRODUCT: Siteminder

COMPONENT: AdminUI

VERSION: Any

OPERATING SYSTEM: Any

 

Cause

The server.log for the Siteminder AdminUI will show an error similar to this:

[<Install_Dir>\SiteMinder\adminui\standalone\log\server.log]

ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC000001: Failed to start service org.wildfly.undertow.listener.default: org.jboss.msc.service.StartException in service org.wildfly.undertow.listener.default: Address already in use: bind /<IP>:<TCPPort>

 

What has occurred is the java process tied to the AdminUI has likely become orphaned.  The java process continues to run, but the corresponding AdminUI process is no longer running.  Either the AdminUI process was stopped or exited abruptly.  Either way, the java process remained running with no dependency.  When the new AdminUI process is started, there is a conflict with the orphaned java process.  This prevents the new AdminUI process from starting.

 

 

Resolution

First, attempt to stop and start the AdminUI.  Then flush browser cache and attempt to connect and login again.  If that doesn't work, then do the following:

1) Stop the Siteminder AdminUI process

WINDOWS:

a) Run 'cmd.exe' with elevated privileges (Run As Administrator)
b) Run the following command:

sc stop smadminui

LINUX:

a) Run the following command:

jboss-cli.sh -c --command=:shutdown

2) Identify the running 'java' processes.

3) There should be no java process running from this path:

<Install_Dir>\SiteMinder\adminuiuntime\bin

4) With the Siteminder AdminUI stopped, kill any 'java' process running from that AdminUI directory.

5) Now you should be able to start the Siteminder AdminUI properly.

WINDOWS:

a) Run 'cmd.exe' with elevated privileges (Run As Administrator)
b) Run the following command:

sc start smadminui

LINUX:

a) Change to the AdminUI /bin directory

cd <Install_Dir>/CA/siteminder/adminui/bin

b) Run the following command:

standalone.sh

 

Alternatively, restarting the AdminUI host will also resolve the issue.