SRM is down with error : http failure response for https://xxxxxx:5480/configure/requestHandlers/isHostReachable: 500 Internal Server Error
search cancel

SRM is down with error : http failure response for https://xxxxxx:5480/configure/requestHandlers/isHostReachable: 500 Internal Server Error

book

Article ID: 396889

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Error in SRM UI appears as below:

    http failure response for https://xxxxxx:5480/configure/requestHandlers/isHostReachable: 500 Internal Server Error

  • SRM site pair will show as Not Connected/Unknown status.

    SRM UI -> Summary -> Site Pair (Site Recovery Manager).



  • nslookup on the VC/SRM appliance SSH session, results in the error: Server can't find FQDN error:

    root@srm01 [ /home/admin ]# nslookup <FQDN>
    Server:        #.#.#.#
    Address:       #.#.#.#

    ** server can't find <FQDN>: NXDOMAIN

Environment

VMware Site Recovery Manager 8.X
VMware Live Recovery 9.x

Cause

  • If the configured DNS servers become unreachable, the Site Recovery Manager (SRM) appliance will become inaccessible. This occurs because SRM relies on DNS to resolve and communicate with critical infrastructure components, such as vCenter Server and the paired SRM site.

Resolution

  • Engage Networking/Firewall team to validate firewall rules/ADDS configured.

Workaround

  • To work around this issue, add the vCenter, SRM and VRMS  IP and FQDN for both paired sites in the /etc/hosts file on both SRM, vCenter and VR appliances.

  • To add the vCenter IP and FQDN:
    1. Log in to Site Recovery Manager Appliance console.
    2. Run these commands:

      cd /etc
      cp hosts hosts.bak
       (to create back for host file)
      vi hosts

    3. Enter I key to enable insert mode.
    4. Move the cursor, create an entry for vCenter, SRM and VRMS IP and FQDN for both sites below the local host entry.

      Example of host's file:

      # VAMI_EDIT_BEGIN
      127.x.x.x localhost
      192.xxx.x.xx srmr-a.example.local srmr-a
      # VAMI_EDIT_END

    5. Add the vCenter IP and FQDN after Site Recovery manager Appliance IP and FQDN.

      Example of hosts file after the change:

      # VAMI_EDIT_BEGIN
      127.x.x.x localhost
      192.168.x.xx srmr-a.example.local srmr-a
      192.167.x.xx vcprod.example.local vcprod
      192.166.x.xx vr.example.local vr
      # VAMI_EDIT_END

    6. Refresh the SRM DR UI page/Reconnect the Pair.