Error "500 OK" while trying to open a Catalog Item in Aria Automation Service Broker
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Error "500 OK" while trying to open a Catalog Item in Aria Automation Service Broker

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Article ID: 396830

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms

  • When using a user with the "Service Broker User" role, you encounter a "500 OK" error in the UI when accessing a catalog item.
  • The following messages are observed in the form-service-app.log file located at /services-logs/prelude/form-service-app/file-logs:
    ERROR form-service [host='form-service-app-###' thread='reactor-http-epoll-4' user='' org='' trace='' parent='' span=''] o.s.b.a.w.r.e.AbstractErrorWebExceptionHandler - [###]  500 Server Error for HTTP POST "/form-service/api/forms/renderer/model?formType=requestForm&isUpdateAction=false&formId=####&projectId=&resourceId=&deploymentId=&sourceType=com.vmw.vro.workflow&sourceId=###"
    
            java.lang.NullPointerException: Cannot invoke "com.vmware.vcac.forms.model.schema.constraints.Constraints.getMinConstraint()" because the return value of "com.vmware.vcac.forms.model.schema.FormSchemaField.getConstraints()" is null

Environment

Aria Automation 8.18.0

Cause

  • This occurs because the form design is incorrect. There are constraints with a null values in the form.

Resolution

The form design for that catalog product should be reviewed. You must navigate to Service Broker -> Content&Policies ->Content using an admin account to review it.

Once the null values ​​have been removed from the constraints section, the user will be able to access the catalog item.