Day 2 Actions Not Working in Aria Automation After Azure VM Moved to New Availability Set
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Day 2 Actions Not Working in Aria Automation After Azure VM Moved to New Availability Set

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Article ID: 396809

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • User deploys a VM from Aria Automation to Azure and changes Update Settings to reflect "Enabled / Customer Managed Schedules"
  • User changes Availability Set of Aria Automation deployed VMs in Azure and changes Update Settings to "Disabled / Image Default".
  • User then changes Update Settings on Portal to "Enabled / Customer Managed Schedule"

Environment

  • Aria Automation 8.x
  • Microsoft Azure (using Availability Set)

Cause

  • This is not possible in Aria Automation 8.x by design.
  • Swapping the Availability Set of a Virtual Machine directly in Azure can cause a synchronization issue between Azure and Aria Automation 8.x, leading to a state that cannot be cleanly recovered within Aria Automation.

  • This occurs because the Azure cloud state and the Aria Automation database become inconsistent.

Resolution

  • Currently, there is no supported or documented method to resynchronize these states without modifying the underlying code, which is not recommended.