Issue while changing PNID via VAMI page of vCenter.
search cancel

Issue while changing PNID via VAMI page of vCenter.

book

Article ID: 396795

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to change the Platform Services Controller Node ID (PNID) through the vCenter Server Appliance Management Interface (VAMI), the operation fails with an error message: The specified SSO username is not valid, accepted user is administrator@<domain_name>.

Cause

Entry for the default vCenter Single Sign-On (SSO) administrator user ([email protected]) is missing from the vmdir.username configuration file. The PNID change process requires this specific user entry to be present in the vCenter Directory Service (vmdir) configuration.

Resolution

Ensure to take a backup of the vCenter Server Virtual Machine before performing any changes Snapshot Best practices for vCenter Server Virtual Machines

To implement the fix, the missing SSO user entry must be added manually to the vCenter configuration file.

  • An SSH connection must be established to the vCenter Server and login as a root user
  • Navigate to the installation defaults directory : cd /etc/vmware/install-defaults
  • Open the vmdir.username configuration file for editing using the vi editor : vi vmdir.username
  • Enter INSERT mode by pressing the i key and Add the default SSO user on a new line: [email protected]
  • Exit INSERT mode by pressing the Esc key and Save the changes and quit the editor using the command: :wq! and press Enter

The PNID change operation should be re-initiated via the VAMI page.