"RSA public key is not available client side (option serverRsaPublicKeyFile not set)" CABI error after upgrade
search cancel

"RSA public key is not available client side (option serverRsaPublicKeyFile not set)" CABI error after upgrade

book

Article ID: 396794

calendar_today

Updated On:

Products

Network Observability Spectrum

Issue/Introduction

after upgrading to the new CABI version the reports didn't work ("error creating connection").

I tested the connections to the SRM in /root/Public/ca/Spectrum/datasources, but got the following error: 

java.sql.SQLException: Could not connect to address=(host=<HOST>)(port=3306)(type=master) : RSA public key is not available client side (option serverRsaPublicKeyFile not set) at org.mariadb.jdbc.internal.util.exceptions.ExceptionMapper.get(ExceptionMapper.java:262) 
...

Environment

Release : 23.3, 24.3

Component : Jaspersoft for CA Spectrum

Cause

Jaspersoft appends &allowPublicKeyRetrieval=true to the database connection string. It is possible jaspersoft is incorrectly assuming that there
   are other post variables and it is appending one more. Since this is the first post variable '?' is needed after the database name and before the first variable.

Resolution

Additional Information

This is another symptom of a problem documented in the above link.