HCX 443 UI shows : "HCX system is deactivated: Please contact your administrator for assistance"
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HCX 443 UI shows : "HCX system is deactivated: Please contact your administrator for assistance"

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Article ID: 396778

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Updated On:

Products

VMware HCX

Issue/Introduction

  • HCX reports error in 443 UI "HCX system is deactivated: Please contact your administrator for assistance"



  • Below error would be noticed: /common/logs/admin/web.log
    <timestamps> UTC [https-jsse-nio-127.0.0.1-8443-exec-9, Ent: HybridityAdmin, , TxId: TxId: ####-####-####] ERROR c.v.h.i.util.InterconnectFeatureUtil- HCX service communication check failed for endpoint <hcx-manager-fqdn/ip> (<System ID-hcx-node>). Communication to HCX service is broken for more than grace time.

Environment

HCX 4.10.3 and earlier versions

Cause

  • HCX service gets deactivated when the HCX Manager loses connection to "connect.hcx.vmware.com" for over 7 days.
  • This is expected behavior.

Resolution

  • Make sure the HCX version is not End of General Support (EoGS) by checking Broadcom's Lifecycle Matrix page - Product Lifecycle Page
    • Select Division as "VMware Cloud Foundation" and mention VMware HCX in Product Name

  • Ensure there is a stable connectivity to "connect.hcx.vmware.com"
  • The connectivity could be confirmed by logging into the HCX Manager as user admin via SSH and run the command below
      • curl -kv https://connect.hcx.vmware.com
      • If using Proxy : curl -kv https://connect.hcx.vmware.com --proxy <proxy-fqdn-ip>:<proxy-port>

  • Take note of the affected HCX 'System ID.'
    • To find the System ID in the UI, go to the 'System Updates' section on the HCX Hybridity page."




  • Export the HCX log bundle including DB and open a Support Request with Broadcom. Reference - Creating and managing Broadcom support cases