MCS - logmon profile stuck in "Pending" status
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MCS - logmon profile stuck in "Pending" status

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Article ID: 396767

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We're looking into deploying some MCS Profiles and Alarm Policies and are having some trouble with a simple MCS Logmon profile that is stuck in Pending. I simply created the base profile, and then clicked on Customize Monitoring which then threw it back to the main profile screen with status of Pending. 

After waiting several minutes I started walking through troubleshooting steps listed in this documentation, but haven't had any luck.  The checksums were computed, I see the CRS probe cached the required checksums via the callback, etc...

Article: https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/monitoring/infrastructure-core-components/configuration-reader-service/configuration-reader-service-troubleshooting.html

I've cycled both the configuration_reader_service and mon_config_service probes.  And then eventually the entire primary hub robot that these probes are loaded on.  I've read about deploying additional CRS probes on secondary hubs, but that shouldn't be a factor here I would think because I'm testing the MCS profile on a robot that is directly under the primary hub.

Environment

  • DX UIM 23.4 CU4
  • mon_config_service: 23.4.4
  • robot 23.4.4
  • hub 23.4.4

Cause

  • Profile was deployed to a hub not a 'target' robot.

Resolution

Tried to delete the profile and re-add/redeploy it but it remained greyed out. The profile was deployed to the hub-robot.
 
--Identify the error state profiles:
select profileId from ssrv2profile where status='error'
 
--Delete the profile configurations related to the error state profiles:
 
delete from ssrv2configvalue where profile in (select profileId from ssrv2profile where status='error')
--Delete the locked Red cross profiles:
 
delete from ssrv2profile where status='error'
 
profileId was 488
 
select * from SSRV2ProfileCheckSum where profile=488
 
delete from the checksum table first

delete from ssrv2profile where ProfileId = 488
select * from SSRV2ProfileCheckSum where profile=488
delete from SSRV2ProfileCheckSum where profile=488
 
Then we were able to redeploy the profile to the target robot.