Error: "There were errors while downloading one or more software packages" after applying new Lifecycle Manager download token URL
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Error: "There were errors while downloading one or more software packages" after applying new Lifecycle Manager download token URL

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Article ID: 396760

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Updated On: 05-08-2025

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

  • After adding the 4 new URLs within Lifecycle Manager > Settings > Patch Setup, when attempting to update an ESXi host, the following error message appears:

    Remediation did not succeed for <host name>. There were errors while downloading one or more software packages. Check the VMware vSphere Lifecycle Manager network connectivity settings

  • vCenter events show Update Manager Update Download was successful

    vpxd[6771]: Event [100005818] [1-1] [2025-05-05T23:12:01.481855Z] [vim.event.ScheduledTaskStartedEvent] [info] [] [] [100005818] [Running task VMware vSphere Update Manager Update Download on Datacenters in datacenter ]

    vpxd[6771]: Event [100006012] [1-1] [2025-05-05T23:22:00.278924Z] [vim.event.ScheduledTaskCompletedEvent] [info] [com.vmware.vcIntegrity] [] [100006012] [Task VMware vSphere Update Manager Update Download on Datacenters in datacenter  completed successfully]

  • vCenter - /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log show successful curls to the new URLs

    2025-05-05T17:49:02.069-06:00 info vmware-vum-server[99340] [Originator@6876 sub=httpDownload] [httpDownloadPosix 769] curl_easy_perform() succeeded - url: https://dl.broadcom.com/<unique_customer_token>/PROD/COMP/ESX_HOST/vmtools-main/vmw-depot-index.xml

Cause

Public facing repository URLs and authentication mechanisms have changed. Download URLs are no longer common but unique for each customer, therefore will require to be re-configured.

Resolution

  1. Ensure the update manager service has been restarted after adding in the 4 new URLs.

    service-control --restart vmware-updatemgr

  2. Download the content by going to vSphere Client Home page → Lifecycle Manager and selecting "ACTIONS" → Updates → Sync updates.

  3. Reattempt to remediate the ESXi host.

Additional Information