Windows System Assessment Scan (WSAS) failure affecting servers only. Works fine on PCs and laptops.
search cancel

Windows System Assessment Scan (WSAS) failure affecting servers only. Works fine on PCs and laptops.

book

Article ID: 396740

calendar_today

Updated On:

Products

Patch Management Solution

Issue/Introduction

The servers in the environment were all failing to run the assessment scans, and therefore they were not able to patch these servers. 

The agent logs showed the following sequence:

  1. Informational: AeXPatchUtil: StartSystemAssessmentScanEx (provider:Shavlik, mode:incremental)
  2. Warning: _com_error exception: Task is set to run from source. The task is intended to be executed on the server location (0x80042C0D)
  3. Error: DownloadToolPackage() - Unexpected exception downloading package {6D417916-467C-46A7-A870-6D86D9345B61}
    • Note: PackageID 6D417916-467C-46A7-A870-6D86D9345B61 refers to the assessment scan package
  1. Error: Package {6D417916-467C-46A7-A870-6D86D9345B61} required for assessment is not available on endpoint
  2. Error: Failed to launch assessment scan for provider: Traditional

 

Cause

Targeted Agent Settings policy for All Windows Servers (excluding 'Site Servers') was configured to run software deliveries from the server instead of the default, download and run locally.

 

 

Resolution

Restored the default setting in the targeted agent settings policy, software delivery tab, download and run section to, "Download and run locally"