Connectivity between Aria Operations for Logs application and vCenter Server application.
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Connectivity between Aria Operations for Logs application and vCenter Server application.

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Article ID: 396650

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Aria Operations for logs not ingesting data from the  vCenter server 
  • Checking connectivity from the Aria Ops for logs to vCenter server by running command on the ssh session from Aria Ops for Logs node:

    curl -v telnet://<VC_node_ip>:443  


    Connection is ok when you see the word "connected"

  • Checking the SSL connectivity from the Aria Operations for Logs to the vCenter server:

    openssl s_client -showcerts -connect <VC_ip>:443

    If this is working as expected then the vCenter's certificate will be populated on the screen 

Environment

Aria Operations For Logs

vCenter Server 

Cause

In a /storage/core/loginsight/var/runtime.log the following can be seen:

Syslog client <IP> disconnected due to a SSL handshake problem.  This may be a problem with the SSL Certificate or with the Network Time Service.  In order for VMware Aria Operations for Logs to accept syslog messages over SSL, a certificate that is validated by the client is required and the clocks of the  systems must be in sync.  Log messages from <IP> are not being accepted, reconfigure that system to not use SSL or see <a href='https://www.vmware.com/support/pubs/log-insight-pubs.html'>Online Help</a> for instructions on how to install a new SSL certificate  .

Resolution

Please configure or check time sync between vCenter and Aria Operations for Logs by running command on both: 

watch date 

if there is time drift between nodes please configure NTP:

Please verify if the vcenter server is configured using a FQDN , if yes, please verify if we can resolve this FQDN from Aria operations for logs node.