Omnissa (Horizon) Instant Clones Not Registering With a Parent Template
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Omnissa (Horizon) Instant Clones Not Registering With a Parent Template

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Article ID: 396588

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

After upgrading to Horizon 8.14 (or higher) Instant Clones are no longer properly registering in the Console with a Parent Template.

Environment

  • App Control Server: All Supported Versions
  • App Control Agent: All Supported Versions
  • Horizon Instant Clones 8.14 or higher

Cause

A rebrand change from VMware to Omnissa has changed configuration settings the Agent relies on to know the client is an Instant Clone.

Resolution

  1. Add the following Agent Config for all Windows Agents in the relevant VDI Policy
    • Name: Omnissa Instant Clone Detection (CRE-21287)
    • Host ID: 0
    • Value:
      VDICustomizationRegistryKey=Software\Omnissa\Horizon\Instant Clone Agent\AgentIntegration
    • Platform: Windows
    • Status: Enabled
    • Create For: All or select the relevant Policy/Policies for Instant Clones
  2. Save and Exit
  3. Boot the Golden Image and complete any/all necessary software updates accordingly.
    • Verify Agent shows as Connected & Up to Date with the Agent Config previously created.
  4. Shutdown the Golden Image.
  5. Complete the Template Image process accordingly.

Additional Information