Within License Management > Licenses > Usage Overview, 1 or more vCenter servers are not showing any license data at all.
You can see license data for vCenter servers that are in the same domain as Aria Operations cluster
The vCenter servers have been added to Aria Operations and are collecting data
If you look at the Infrastructure Health adapter logs that are associated to the Aria Operations node that is trying to collect the license data, you may see the following error
com.vmware.adapter3.vmwareinfrahealth.helpers.vcenter.collector.VCenterLicenseUsageCollector.collect - Cannot fetch license from VC: ..........invocation failed with "java.net.UnknownHostException: <vCenter_FQDN>: Name or service not known
If you try to run nslookup command from the Aria Operations node to the vCenter it will fail
Environment
Aria Operations 8.18.x
Cause
The vCenter servers that are missing license data were added by IP address within the Integrations page
Aria Operations nodes are not able to resolve the IP address or hostname during collection of license data
Resolution
Add the proper DNS entries for the vCenter so IP and FQDN are resolvable by all nodes and cloud proxies in the Aria Operations environment.
In the case of a single node cluster and DNS is not able to be resolved yet, as a workaround only, you can add the vCenter's IP and FQDN to the /etc/hosts file within an SSH session as root to the Aria Operations node
Additional Information
To find the Infrastructure Health adapter logs, navigate to Administration > Control Panel > Support Logs. Determine which data node or cloud proxy is collecting data from the intended vCenter server. Expand the tree for that node to COLLECTOR > adapters > VMwareInfraHealthAdapter. Double click on the log file to view the log details.