In ConnectAll basic authentication method depreciated post upgrading ALM instance to version 25.1
search cancel

In ConnectAll basic authentication method depreciated post upgrading ALM instance to version 25.1

book

Article ID: 396519

calendar_today

Updated On:

Products

ConnectAll SaaS ConnectAll On-Prem ConnectALL

Issue/Introduction

Steps to Reproduce
 

  • Upgrade ALM instance to version 25.1
  • Login to ConnectAll application.
  • Create a new ALM connection or try modifying an existing one using basic authentication.

Expected Results

ALM connection should connect successfully using basic auth option.

Actual Results:

ALM connection dosen't connect using basic auth and throw below error.

ERROR 2025-04-25 10:34:20,021 [748652908 | Test_Automation| Test_Automation_1745577240703 |  | {}][(connectall-flows) thread #205 - Split] com.go2group.connectall.adapter.hpalm.HPALMAdapter: Exception occured when trying to establish QC connection {}
com.go2group.connectall.adapter.model.exception.ConnectAllException: Response Status: 401 Reason: Unauthorized Message {"Id":"qccore.general-error","Title":"Authentication failed. Browser based integrations - to login append '?login-form-required=y' to the url you tried to access.","ExceptionProperties":null,"StackTrace":null}

Environment

3.x

Cause

ALM 25.1 version no more supporting basic authentication for transactions coming via rest API's.

Resolution

  • Create or get the "Client ID" & "Client Secret" for ALM service account configured in ConnectAll
  • Login to ConnectAll application and modify your existing ALM connection.
  • In Authentication Type use OAuth 2.0 and validate the connection using "Client ID" & "Client Secret"

  • Once Connection is successful, navigate to Dashboard and rerun or run your automation to validate ticket sync processing.