SRM service fails to startup after Advanced Settings>Remote Manger timeout parameter changes in SRM UI.
book
Article ID: 396507
calendar_today
Updated On:
Products
VMware Live Recovery
Issue/Introduction
- SRM Advanced Settings > Remote Manger timeout params have been recently changed
- SRM VAMI Reconfigure completes successfully.
- SRM plugin in vCenter UI reports as "not accessible."
- Starting SRM service fails.
# systemctl start srm-server.service
srm-server.service - VMware Site Recovery Manager Server
Loaded: loaded (/lib/systemd/system/srm-server.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2025-05-01 13:47:09 UTC; 45s ago
Process: 3025 ExecStart=/opt/vmware/srm/bin/vmware-dr /opt/vmware/srm/conf/vmware-dr.xml (code=exited, status=240/LOGS_DIRECTORY
Main PID: 3025 (code=exited, status=240/LOGS_DIRECTORY)
- SRM /opt/vmware/support/logs/srm/vmware-dr.log reports backtrace
......... panic vmware-dr[03025] [SRM@6876 sub=Default] Application error: N7Vmacore24InvalidArgumentExceptionE /connections/vcPingInterval
Cause
- SRM cannot connect on newly set Remote Manager settings.
Resolution
- Change the SRM Advanced Settings > Remote Manager bac to default in /opt/vmware/srm/conf/vmware-dr.xml
<remoteManager>
<defaultTimeout>800</defaultTimeout>
<taskCancelDefaultTimeout>250</taskCancelDefaultTimeout>
<taskDefaultTimeout>800</taskDefaultTimeout>
<taskProgressDefaultTimeout>150</taskProgressDefaultTimeout>
<vmGuestShutDownRetryCount>8</vmGuestShutDownRetryCount>
<vmPowerOnRetryCount>8</vmPowerOnRetryCount>
<vmReconfigureRetryCount>4</vmReconfigureRetryCount>
</remoteManager>
Change it back to default value as below and restart service.
<remoteManager>
<defaultTimeout>900</defaultTimeout>
</remoteManager>
- Restart SRM service via cmdline
# systemctl start srm-server.service
Feedback
thumb_up
Yes
thumb_down
No