Software Portal shows error: 'Software Portal must be accessed via the desktop link' after upgrading to 8.7.3.
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Software Portal shows error: 'Software Portal must be accessed via the desktop link' after upgrading to 8.7.3.

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Article ID: 396438

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Recently upgraded to 8.7.3 and now users are not able to use the Software Portal.  URL looks different for old agents. vs. new agents.

Users are getting the error: 'Software Portal must be accessed via the desktop link' message in Software Portal for logged in Domain user.

Environment

8.7.3+

Cause

We added additional Security to users accessing the Software Portal.  For instance, we no longer allow links to be shared among users and systems.  Users must start the Software Portal from the Start Menu, Desktop Icon, or the Symantec Management Agent right-click Menu.

Resolution

First, if you want to go back to the way things were previously, it is necessary to create a Core Setting: SWPAllowCrossMachinesRequest, and set it to TRUE.  That will revert the Software Portal Links to the previous way of working where they can be shared.

Second, there is a bug on the agent side that does not allow the proper Token to be sent by the Agent, and so the URL will be different from a system that works. This issue has been fixed with ITMS 8.8 release.

There is a pointfix available for those with ITMS 8.7.3 release. Install the Cumulative Pointfix for Software Management Solution (SWM) in 8.7.3 to resolve this issue: Cumulative Post ITMS 8.7.3 Point Fixes

 

Additional Information

Cumulative Post ITMS 8.7.3 Point Fixes

What's New in This Release (8.7.3)

"Software Portal must be accessed via the desktop link" message in Software Portal for logged in Domain user (KB 397192)